Présentation de ColorPalette

 Aide de
NPPalPager - Version 2.2

Présentation de NPPalPager
NPPalPager vous permet de lire (PAL Windows), créer, modifier et sauvegarder des palettes de couleurs au format PAL Windows ou PAL Jasc. Vous pouvez récupérer les valeurs Hexadécimale, RGB, Index, Rouge, Vert et Bleu d'une ou plusieurs couleurs sélectionnées.

NPPalPager possèdent de nombreuses propriétés d'apparence, de comportement...Celui-ci est entièrement configurable, vous permettant ainsi, de l'adapter au mieux à vos propres programmes. De nouvelles fonctionnalités viennent s'ajouter dans cette nouvelle version:

Création de palettes
  • Avec vos propres couleurs
  • Dégradé à partir de deux couleurs
Sauvegarde de palettes
  • Format PAL Windows
  • Format PAL Jasc
  • A partir de la palette active
  • NEW: A partir de la palette d'une image
Informations sur la palette active
  • Version
  • Nombre d'entrées
  • Flags
  • Taille
  • Handle
Changement de couleurs
  • Couleur sélectionnée
  • Dégradé entre deux couleurs sélectionnées
Gestion des palettes
  • Récupération des entrées d'une palette (hexa, rgb, composantes rouges, vertes ou bleues)
  • Recherche d'une couleur dans la palette
  • NEW: Chargement et visualisation de la palette d'une image
Nous vous souhaitons d'agréables moments de programmation avec NPPalPager.

http://members.xoom.com/ColorMaster
nathandco@france-mail.com

Copyright © 1998-1999 Nathalie Moret, Pascal Plaza. Tous droits réservés. Windows, Win95, WinNT, ActiveX et Visual Basic sont des marques déposées par Microsoft Corporation.


 Distribution
NPPalPager 2.2 peut être distribué librement dans sa version shareware.

NPPalPager 2.2 est 100% ROYALTY FREE.

Les utilisateurs enregistrés ne doivent en aucun cas transmettre le fichier de licence fourni lors de l'achat de NPPalPager.

Lors de la distribution d'un programme utilisant NPPalPager, vous devez également livrer la dll SSUBTMR.DLL, nécessaire au composant.


 Remerciements
Les auteurs tiennent à remercier toutes les personnes ayant participer à l'évolution de ce produit et plus particulièrement:

Steve McMahon - VBaccelerator
pour ses suggestions quant à certaines propriétés.

Nous attendons vos suggestions, remarques, critiques (constructives) afin de faire évoluer ce produit. Contactez-nous par email ...


Propriété Align

 ALIGN
Renvoie ou définit l'alignement de NPPalPager.

Syntaxe

NPPalPager.Align [= number]

La syntaxe de la propriété Align comprend les éléments suivants :

Elément | Description
number | Entier qui spécifie le mode d’affichage d’un objet, comme indiqué dans la section Valeurs.

Valeurs
L'élément number peut prendre les valeurs suivantes :

Constantes | Valeurs | Description
vbAlignNone | 0 | (Valeur par défaut) Aucun
vbAlignTop | 1 | Haut — l’objet est placé en haut de la feuille et sa largeur est égale à la valeur de la propriété ScaleWidth de la feuille.
vbAlignBottom | 2 | Bas — l’objet est placé en bas de la feuille et sa largeur est égale à la valeur de la propriété ScaleWidth de la feuille.
vbAlignLeft | 3 | Gauche — l’objet est placé à gauche de la feuille et sa largeur est égale à la valeur de la propriété ScaleWidth de la feuille.
vbAlignRight | 4 | Droite — l’objet est placé à droite de la feuille et sa largeur est égale à la valeur de la propriété ScaleWidth de la feuille.


Propriété Border_Style

 BORDER_STYLE
Renvoie ou définit le type de bordure de NPPalPager.

Syntaxe

NPPalPager.Border_Style [= number]

La syntaxe de la propriété Border_Style comprend les éléments suivants :

Elément | Description
number | Entier qui spécifie le type de bordure, comme indiqué dans la section Valeurs.

Valeurs
L'élément number peut prendre les valeurs suivantes :

Constantes | Valeurs | Description
None | 0 | (Valeur par défaut) Aucune
Single | 1 | Bordure simple
3D | 2 | Bordure surélévée
3D Double | 3 | Bordure surélevée double


Propriété Color_Selected

 COLOR_SELECTED()
Définit la/les couleur(s) sélectionnée(s).

Syntaxe

NPPalPager.Color_Selected(Index) [= number]

La syntaxe de la propriété Color_Selected comprend les éléments suivants :

Elément | Description
Index | Valeur de type integer représentant l'index dans le tableau des couleurs sélectionnées. L'index 0 indique qu'UNE SEULE couleur est sélectionnée.
number | Valeur de type integer représentant l'index de/des couleur(s) à sélectionner.

Exemple

Sélection unique
NPPalPager1.Color_Selected(0)=15
-->La couleur sélectionnée sera l'index 15 dans la palette.

Sélection multiple
Dim I as Integer
For I= 12 to 24
NPPalPager1.Color_Selected(I-12) = I
Next I
-->Les couleurs sélectionnées seront de l'index 12 à l'index 24 dans la palette. L'index de la propriété Color_Selected doit toujours commencé par 0, c'est pourquoi nous enlevons 12 à I.


Propriété ErrMessage

 ERRMESSAGE
Renvoie ou définit le contenu du message à afficher lors d'une erreur de lecture d'un fichier palette.

Syntaxe

NPPalPager.ErrMessage [= string]

La syntaxe de la propriété ErrMessage comprend les éléments suivants :

Elément | Description
string | Chaine affichée comme message dans la boite de dialogue.

Exemple

NPPalPager1.ErrMessage= "Une erreur s'est produite lors de
l'ouverture du fichier."


Propriété ErrTitle

 ERRTITLE
Renvoie ou définit le titre affiché dans la barre de titre de la boîte de dialogue ErrMessage.

Syntaxe

NPPalPager.ErrTitle [= string]

La syntaxe de la propriété ErrTitle comprend les éléments suivants :

Elément | Description
string | Chaine affichée comme titre de la boite de dialogue.

Exemple

NPPalPager1.ErrTitle= App.EXEName & " - Erreur"


Propriété GridColor

 GRIDCOLOR
Renvoie ou définit la couleur de la grille.

Syntaxe

NPPalPager.GridColor [= color]

La syntaxe de la propriété GridColor comprend les éléments suivants :

Elément | Description
color | Couleur à utiliser.


Propriété GridLineWidth

 GRIDLINEWIDTH
Renvoie ou définit l'épaisseur de la grille.

Syntaxe

NPPalPager.GridLineWidth [= number]

La syntaxe de la propriété GridColor comprend les éléments suivants :

Elément | Description
number | Nombre entier spécifiant l'épaisseur de la grille en pixels.


Propriété GridShowFocus

 GRIDSHOWFOCUS
Renvoie ou définit si le focus de sélection d'une couleur est visible.

Syntaxe

NPPalPager.GridShowFocus [= boolean]

La syntaxe de la propriété GridShowFocus comprend les éléments suivants :

Elément | Description
boolean | True ou False.


Propriété GridSize

 GRIDSIZE
Renvoie ou définit la taille des cellules de la grille.

Syntaxe

NPPalPager.GridSize [= number]

La syntaxe de la propriété GridSize comprend les éléments suivants :

Elément | Description
number | Nombre entier spécifiant la taille des cellules de la grille en pixels.


Propriété GridStyle

 GRIDSTYLE
Renvoie ou définit le type d'affichage de la grille.

Syntaxe

NPPalPager.GridStyle [= number]

La syntaxe de la propriété GridStyle comprend les éléments suivants :

Elément | Description
number | Entier qui spécifie le type de grille, comme indiqué dans la section Valeurs.

Valeurs
L'élément number peut prendre les valeurs suivantes :

Constantes | Valeurs | Description
Solid | 0 | (Valeur par défaut) La grille est visible
Transparent | 5 | La grille est invisible


Propriété GridStyleFocus

 GRIDSTYLEFOCUS
Renvoie ou définit le type d'affichage du focus de sélection.

Syntaxe

NPPalPager.GridStyleFocus [= number]

La syntaxe de la propriété GridStyleFocus comprend les éléments suivants :

Elément | Description
number | Entier qui spécifie le type de focus, comme indiqué dans la section Valeurs.

Valeurs
L'élément number peut prendre les valeurs suivantes :

Constantes | Valeurs | Description
Mono | 0 | (Valeur par défaut) Le focus sera représenté par un carré blanc entouré de noir.
Bdr_RaisedOuter | 1 | Le focus sera représenté par un carré 3D surélevé "soft". Ombrage à droite
Bdr_SunkenOuter | 2 | Le focus sera représenté par un carré 3D rabaissé "soft". Ombrage à droite
Bdr_RaisedInner | 4 | Le focus sera représenté par un carré 3D surélevé "soft". Ombrage à gauche
Edge_Raised | 5 | Le focus sera représenté par un carré 3D surélevé "hard". Ombrage à gauche
Edge_Etched | 6 | Le focus sera représenté par un carré 3D incrusté.
Bdr_SunkenInner | 8 | Le focus sera représenté par un carré 3D rabaissé "soft". Ombrage à gauche
Edge_Bump | 9 | Le focus sera représenté par un carré disposant d'une bordure 3D double surélevée.
Edge_Sunken | 10 | Le focus sera représenté par un carré 3D rabaissé "hard". Ombrage à gauche


Propriété MaxSelected

 MAXSELECTED
Renvoie le nombre de couleurs sélectionnées. Celle-ci se comporte comme la propriété ListCount d'une zone de liste, à part qu'elle ne prend en compte que la sélection.

Syntaxe

NPPalPager.MaxSelected

Exemple

For A = 0 To NPPalPager1.MaxSelected - 1
    List1(0).AddItem NPPalPager1.Valeur_INDEX(A)
Next A
-->On récupère les valeurs hexa de toutes les couleurs sélectionnées.


Propriété Orientation

 ORIENTATION
Renvoie ou définit l'orientation de NPPalPager.

Syntaxe

NPPalPager.Orientation [= number]

La syntaxe de la propriété Orientation comprend les éléments suivants :

Elément | Description
number | Entier qui spécifie l'orientation, comme indiqué dans la section Valeurs.

Valeurs
L'élément number peut prendre les valeurs suivantes :

Constantes | Valeurs | Description
Horizontal | 0 | (Valeur par défaut) NPPalPager est affiché horizontalement.
Vertical | 1 | NPPalPager est affiché verticalement.


Propriété Palette

 PALETTE
Renvoie ou définit la palette de couleurs à afficher.

Syntaxe

NPPalPager.Palette [= string]

La syntaxe de la propriété Palette comprend les éléments suivants :

Elément | Description
string | Chemin complet de la palette (au format PAL Windows). Vous pouvez définir cette propriété par le biais de l'option "Personnalisé" ou pendant l'execution.

Exemple
On Error GoTo ErrPal
NPPalPager1.Palette = "c:\esd.pal"
ErrPal:
NPPalPager1.ErrMessage = "Erreur de lecture du fichier " & NPPalPager1.Palette & "."
NPPalPager1.ErrTitle = App.EXEName


Propriété Red, Green, Blue

 RED, GREEN, BLUE
Renvoie la composante Rouge, Verte ou bleu de/des couleur(s) sélectionnée(s).

Syntaxe

NPPalPager.Red(Index)
NPPalPager.Green(Index)
NPPalPager.Blue(Index)

La syntaxe des propriétés Red, Green et Blue comprend les éléments suivants :

Elément | Description
Index | Valeur de type integer représentant l'index dans le tableau des couleurs sélectionnées. L'index 0 indique qu'UNE SEULE couleur est sélectionnée.

Exemple

Récupération unique
Label1(0).Caption = NPPalPager1.Red(0)
Label1(1).Caption = NPPalPager1.Green(0)
Label1(2).Caption = NPPalPager1.Blue(0)
-->On récupère les composantes rouges, vertes et bleues de la couleur sélectionnée et on les affecte aux labels.

Récupération multiple
For A = 0 To NPPalPager1.MaxSelected - 1
    List1(0).AddItem NPPalPager1.Red(A)
    List1(1).AddItem NPPalPager1.Green(A)
    List1(2).AddItem NPPalPager1.Blue(A)
Next A
-->On récupère les composantes rouges, vertes et bleues de toutes les couleurs sélectionnées et on les ajoute aux zones de liste.


Propriété ToolTip

 TOOLTIP
Renvoie ou définit si l'info-bulle doit être affiché lors du survol d'une couleur.

Syntaxe

NPPalPager.ToolTip [= boolean]

La syntaxe de la propriété ToolTip comprend les éléments suivants :

Elément | Description
boolean | True ou False.


Propriété Valeur_Hexa, Valeur_Rgb, Valeur_Index

 VALEUR_HEXA, VALEUR_RGB, VALEUR_INDEX
Renvoie la valeur hexa, RGB, Index de/des couleur(s) sélectionnée(s).

Syntaxe

NPPalPager.Valeur_HEXA(Index)
NPPalPager.Valeur_RGB(Index)
NPPalPager.Valeur_INDEX(Index)

La syntaxe des propriétés Valeur_Hexa, Valeur_Rgb, Valeur_Index comprend les éléments suivants :

Elément | Description
Index | Valeur de type integer représentant l'index dans le tableau des couleurs sélectionnées. L'index 0 indique qu'UNE SEULE couleur est sélectionnée.

Exemple

Récupération unique
Label1(0).Caption = NPPalPager1.Valeur_HEXA(0)
Label1(1).Caption = NPPalPager1.Valeur_RGB(0)
Label1(2).Caption = NPPalPager1.Valeur_INDEX(0)
-->On récupère la valeur hexa, RGB et Index de la couleur sélectionnée et on les affecte aux labels.

Récupération multiple
For A = 0 To NPPalPager1.MaxSelected - 1
    List1(0).AddItem NPPalPager1.Valeur_HEXA(A)
    List1(1).AddItem NPPalPager1.Valeur_RGB(A)
    List1(2).AddItem NPPalPager1.Valeur_INDEX(A)
Next A
-->On récupère les valeurs hexa, RGB et Index de toutes les couleurs sélectionnées et on les ajoute aux zones de liste.


Fonction ChangeColor

 CHANGECOLOR
Cette fonction vous permet de modifier la couleur sélectionnée.

Syntaxe

NPPalPager.ChangeColor NewColor

La syntaxe de la méthode ChangeColor comprend les éléments suivants :

Elément | Description
NewColor | Valeur de type long représentant la nouvelle couleur.

Exemple

NPPalPager1.ChangeColor RGB(255, 255, 0)
NPPalPager1.ChangeColor &HFFFF00


Fonction CreateFadePalette

 CREATEFADEPALETTE
Cette fonction vous permet de créer une palette de dégradé de couleurs.

Syntaxe

NPPalPager.CreateFadePalette RgbStart, RgbStop, Steps

La syntaxe de la méthode CreateFadePalette comprend les éléments suivants :

Elément | Description
RgbStart | Valeur de type long représentant la couleur de départ.
RgbStop | Valeur de type long représentant la couleur de fin.
Steps | Valeur de type integer représentant le nombre de couleurs intermédiaires à générer.

Exemple

NPPalPager1.CreateFadePalette RGB(255, 255, 0), RGB(255,0,0), 255
-->Créé une palette de 256 couleurs en dégradé de jaune vers rouge.


Fonction CreatePal

 CREATEPAL
Cette fonction vous permet de créer une palette de couleurs.

Syntaxe

NPPalPager.CreatePal PpRed(), pGreen(), pBlue(), Entries

La syntaxe de la méthode CreatePal comprend les éléments suivants :

Elément | Description
pRed() | Valeur de type byte représentant les composantes ROUGES.
pGreen() | Valeur de type byte représentant les composantes VERTES.
pBlue() | Valeur de type byte représentant les composantes BLEUES.
Entries | Valeur de type integer représentant le nombre de couleurs à générer.

Exemple

Dim Rouge(16) As Byte, Vert(16) As Byte, Bleu(16) As Byte
     Dim R as Integer

            For R = 0 To 15
                Rouge(R) = 255 - (R * 15)
                Vert(R) = 255 - (R * 15)
                Bleu(R) = 255 - (R * 15)
            Next R

      Call NPPalPager1.CreatePal(Rouge, Vert, Bleu, 16)
      NPPalPager1.Refresh
-->Créé une palette de 16 couleurs en dégradé de blanc vers noir.


Fonction FadeColors

 FADECOLORS
Cette fonction vous permet de créer un dégradé entre deux couleurs sélectionnées.

Syntaxe

NPPalPager.FadeColors

Exemple

NPPalPager1.FadeColors
-->Créé un dégradé de couleurs entre les deux couleurs sélectionnées.


Fonction GetEntries

 GETENTRIES
Cette fonction vous permet de récupérer les entrées d'une palette de couleurs.

Syntaxe

NPPalPager.GetEntries Index, Values

La syntaxe de la méthode GetEntries comprend les éléments suivants :

Elément | Description
Index | Valeur de type integer représentant l'index de la couleur recherchée.
Values | Valeur de type TypeColor représentant le type de valeurs à renvoyer. Cet élément peut prendre les valeurs suivantes: HEXA: Valeurs hexadécimales PRed: Composantes rouges PGreen: Composantes vertes PBlue: Composantes bleues RVB: Valeurs rgb.

Exemple

Dim NumEntries
    NumEntries = NPPalPager1.GetInfo([Pal NumEntries])
    For i = 0 To NumEntries - 1
        List1.AddItem NPPalPager1.GetEntries(i, HEXA)
    Next i
-->Récupère les valeurs hexadécimale de toutes les entrées de la palette et les placent dans une zone de liste.


Fonction GetInfo

 GETINFO
Cette fonction vous permet de récupérer des informations sur une palette de couleurs.

Syntaxe

NPPalPager.GetInfo Inf

La syntaxe de la méthode GetInfo comprend les éléments suivants :

Elément | Description
Inf | Valeur de type InfoPal représentant le type d'information à renvoyer. Cet élément peut prendre les valeurs suivantes: Handle: Handle de palette Pal Flags: Type de Drapeaux utilisé lors de la création Pal NumEntries: Nombre de couleurs dans la palette Pal Size: Taille de la palette (octets) Pal Version: Version de la palette.

Exemple

List1.AddItem "Version: " & NPPalPager1.GetInfo([Pal Version])
List1.AddItem "Nb Entrées: " & NPPalPager1.GetInfo([Pal NumEntries])
List1.AddItem "Flags: " & NPPalPager1.GetInfo([Pal Flags])
List1.AddItem "Size: " & NPPalPager1.GetInfo([Pal Size])
List1.AddItem "Handle: " & NPPalPager1.GetInfo(Handle)


Fonction GetPalPicture

 GETPALPICTURE
Cette fonction vous permet de charger et afficher la palette de couleurs d'une image contenu dans un contrôle PictureBox.

Syntaxe

NPPalPager.GetPalPicture hPalette

La syntaxe de la méthode GetPalPicture comprend les éléments suivants :

Elément | Description
hPalette | Valeur de type long représentant l'handle de palette d'une image affichée.

Exemple

      NPPalPager1.GetPalPicture Picture1.Picture.hPal
-->Charge et affiche la palette de l'image contenu dans le contrôle Picture1.


Fonction SavePalette

 SAVEPALETTE
Cette fonction vous permet de sauvegarder une palette de couleurs.

Syntaxe

NPPalPager.SavePalette FileName, TypePal, [hPalette]

La syntaxe de la méthode SavePalette comprend les éléments suivants :

Elément | Description
FileName | Chaine de type string représentant le chemin complet et le nom du fichier à enregistrer.
TypePal | Valeur de type TypeSavePal représentant le type de palette à sauvegarder. Cet élément peut prendre les valeurs suivantes: PalWin: La palette sera enregistrée au format PAL Windows. PalJasc: La palette sera enregistrée au format PAL Jasc
hPalette (Optional) | Valeur de type long représentant l'handle de palette d'une image.

Exemple 1: Sauvegarde de la palette active (affichée dans NPPalPager)

CommonDialog1.Flags = &H200002
CommonDialog1.ShowSave
If Err <> 32755 Then
   NPPalPager1.SavePalette CommonDialog1.filename, PalWin
End If
-->Sauvegarde la palette active au format PAL Windows.

Exemple 2: Sauvegarde de la palette d'une image

CommonDialog1.Flags = &H200002
CommonDialog1.ShowSave
If Err <> 32755 Then
   NPPalPager1.SavePalette CommonDialog1.filename, PalJasc, Picture1.Picture.hPal
End If
-->Sauvegarde la palette de l'image affichée dans le contrôle Picture1 au format PAL Jasc.


Fonction SearchColor

 SEARCHCOLOR
Cette fonction vous permet de rechercher une couleur donnée dans la palette.

Syntaxe

NPPalPager.SearchColor Color, TypeSearch

La syntaxe de la méthode SearchColor comprend les éléments suivants :

Elément | Description
Color | Valeur de type long représentant la couleur à rechercher.
TypeSearch | Valeur de type TypeColorSearch représentant le type de couleur à rechercher. Cet élément peut prendre les valeurs suivantes: sHEXA: Valeurs hexadécimales sRVB: Valeurs rgb.

Exemple

NPPalPager1.SearchColor RGB(255, 147, 89), sRVB
-->Si la couleur n'est pas présente dans la palette, la couleur la plus proche sera sélectionnée.


Evènements

Liste des évènements disponibles
NPPalPager ne possède aucun évènement particulier. Les évènements par défaut sont disponibles:

Elément | Description
Click | Se produit lorsque l'utilisateur clique sur NPPalPager (bouton droit ou gauche).
DblClick | Se produit lorsque l'utilisateur double-clique sur NPPalPager (bouton droit ou gauche).
KeyDown | Se produit lorsque l'utilisateur enfonce une touche lorsque NPPalPager à le focus.
KeyUp | Se produit lorsque l'utilisateur relache une touche lorsque NPPalPager à le focus.
KeyPress | Se produit lorsque l'utilisateur appuie puis relache une touche ANSII.
MouseDown | Se produit lorsque l'utilisateur enfonce un bouton de la souris.
MouseMove | Se produit lorsque l'utilisateur déplace la souris sur NPPalPager.
MouseUp | Se produit lorsque l'utilisateur relache un bouton de la souris.


 Utilisation
Comment sélectionner plusieurs couleurs continues:
Cliquez avec votre souris sur une couleur puis, tout en maintenant la touche SHIFT de votre clavier enfoncée, cliquez sur une autre couleur dans la palette. Les couleurs intermédiaires seront automatiquement sélectionnées.

Comment sélectionner plusieurs couleurs discontinues:
Cliquez avec votre souris sur une couleur puis, tout en maintenant la touche CTRL de votre clavier enfoncée, cliquez sur une ou plusieurs autres couleurs dans la palette.

NPPalPager 2.2 est livré avec un exemple Visual Basic. Consultez celui-ci pour un aperçu des possibilités de NpPalPager.


Comment s'enregistrer

 Suite à la réception de votre paiement, nous vous enverrons par courrier électronique ou courrier (poste) l'ocx ainsi que son fichier de licence.

Lorsque vous vous enregistrez, vous bénéficiez des avantages suivants :

  • Toutes les révisions sont gratuites
  • un rabais de 50% est applicable sur la prochaine version
  • le support est gratuit pendant une période de 1 mois via Internet.
Prix de NPPalPager 2.2 par envoi du numéro de série par courrier électronique :

Prix de vente 250 FF - 45$US

Mode de paiement :

Par chèque à l'ordre de Nathalie Moret.

Nous traiterons votre enregistrement dans les 48 heures qui suivent le dépot du chèque.

Envoyez votre paiement à l'adresse suivante :
Nathalie Moret
15, Le Puy
37500 Cravant Les Côteaux


Bon d'enregistrement
A imprimer (Cliquez sur la feuille à l'aide du bouton droit de la souris et choisissez Imprimer)

NPPalPager 2.2

Prénom et Nom : ____________________________________________________

Société: ___________________________________________________________

Adresse:___________________________________________________________

Ville:____________________________ Province : _________________________

Pays:___________________________ Code postal : _______________________

Tél.:__________________________ Fax : ________________________________

Adresse électronique : ________________________________________________

Comment avez-vous entendu parler de NPPalPager:

Mode de paiement :
 Chèque (libellé à l'ordre de Nathalie Moret.)

Montant du paiement :
Envoi de l'ocx et de son fichier de licence par courrier électronique | Envoi de disquettes par la poste
 250FF - 45$US |  295FF - 59$US

Signature:__________________________ Date : __________________________

________________________________________________________________________________
Adressez ce bon d'enregistrement ainsi que votre règlement à :
Nathalie Moret - 15, Le Puy - 37500 Cravant Les Côteaux


Licence

Licence d'utilisation
LISEZ ATTENTIVEMENT LES MODALITÉS SUIVANTES SUR LA LICENCE D'UTILISATION DE NPPALPAGER 2.2.

LES DROITS LIMITÉS SUIVANTS VOUS SONT CONCÉDÉS:

a. Une licence, non exclusive et non transférable, afin d'utiliser NPPalPager 2.2 version partagiciel (shareware).

b. Distribuer le programme sous sa forme partagiciel (shareware) à des tiers à condition que ces derniers acceptent les modalités de ce contrat.

IL EST STRICTEMENT INTERDIT:

a. De mofidier le programme en tout ou en partie.

b. De décompiler ou reconstituer le programme.

c. Pour les usagers enregistrés, il est strictement interdit de transmettre son fichier de licence à des tiers.

SI VOUS EFFECTUEZ UNE DES OPÉRATIONS CI-DESSUS, VOS DROITS D'UTILISATION SONT AUTOMATIQUEMENT RÉSILIÉS. CETTE RÉSILISATION VIENT S'AJOUTER AUX RECOURS EN MATIÈRE PÉNALE, CIVILE OU AUTRE DONT LES AUTEURS PEUVENT SE PRÉVALOIR.

GARANTIE LIMITÉE:

ABSENCE DE RESPONSABILITÉ POUR LES DOMMAGES INDIRECTS. Les auteurs ne pourront être tenus responsables en aucune circonstance de tout dommage quel qu'il soit (y compris mais non de façon limitative, les dommages directs ou indirects causés par la perte de bénéfices commerciaux, l'interruption des affaires, la perte d'information commerciale ou toute autre perte pécuniaire) résultant de l'utilisation ou de l'impossibilité d'utilisation de ce produit.

Ce programme est fourni et concédé sous licence «TEL QUEL», sans garantie d'aucune sorte, expresse ou tacite, y compris, sans limitation, garanties implicites de valeur marchande et d'adaptabilité à des fins particulières. Les auteurs, la production ou la livraison du programme, ne seront pas tenus responsables sous n'importe quelles circonstances, de tout dommage direct ou indirect incluant les dommages pour pertes de profits, cessation d'activités commerciales ou autre, subis par l'utilisateur de ce programme et ce, même dans le cas où les auteurs auraient été informés de tels dommages.

Les résultats ou performances de ce programme sont entièrement assumés par l'utilisateur. Les auteurs peuvent révoquer cette licence en tout temps en avisant l'utilisateur du programme. L'utilisateur peut mettre fin à la licence d'utilisation en détruisant ou en effaçant toute copie du programme.

Cette garantie limitée sera interprétée sous gouverne et en accord avec la loi française.

PROPRIÉTÉ:

Le programme, y compris son code, sa documentation, son apparence, sa structure et son organisation, est un produit exclusif des auteurs Nathalie Moret et Pascal Plaza, qui conservent en permanence les droits de propriété du programme ou de ses copies, modifications ou parties fusionnées.